Resolved
We are marking this as resolved now. Thank you for your patience!
Monitoring
Our 3rd party provider has deployed a fix and services are returning to normal. METARs should be updating normally. We'll continue to monitor to ensure everything is fully restored.
Investigating
Due to an issue with our 3rd-party provider, we're currently not receiving any new METARs more recent than April 5th, 1200Z. We're monitoring the provider's status updates and will share any developments as they come.